Funciones lógicas en Excel

Las funciones lógicas en Excel son muy utilizadas para la toma de decisiones, ya que nos permiten evaluar si se cumple o no una condición dada y en relación al resultado, determinar si se ejecutará o no una acción que hayamos establecido.

Que son funciones lógicas en Excel

Son funciones que nos permiten el uso de valores lógicos o evaluar los valores de manera lógica con diferentes finalidades. Las funciones lógicas nos permiten el uso de operadores lógicos como por ejemplo: “Operador Y” y el “operador O”. Los operadores también son conocidos como conectores lógicos.

Cuáles son las funciones lógicas en Excel

A continuación, encontrarás un listado con todas las funciones lógicas en Excel. Al hacer clic sobre cada una de ellas, conocerás qué es lo que hace cada función y la sintaxis para emplearla correctamente.

FALSONOO
SISI.ERRORSI.ND
VERDADEROXOY

Descripciones y sintaxis de las funciones lógicas

FUNCIÓN FALSO

  • Descripción: Devuelve el valor lógico FALSO.
  • Sintaxis: FALSO()
  • Ejemplo: FALSO() = FALSO

FUNCIÓN NO

  • Descripción: Cambia FALSO por VERDADERO y VERDADERO por FALSO.
  • Sintaxis: NO(valor_lógico)
    • valor_lógico (obligatorio): Valor o expresión a evaluar como FALSO o VERDADERO.
  • Ejemplo:
    • NO(VERDADERO) = FALSO
    • NO(FALSO) = VERDADERO

FUNCIÓN O

  • Descripción: Comprueba si alguno de los argumentos es VERDADERO y devuelve VERDADERO o FALSO. Devuelve FALSO si todos los argumentos son FALSO.
  • Sintaxis: O(valor_lógico1, [valor_lógico2], …)
    • valor_lógico1 (obligatorio): Primera condición a probar.
    • valor_lógico2 (opcional): Condiciones adicionales a probar.

Son entre 1 y 255 condiciones que se desean comprobar y que pueden ser VERDADERO o FALSO

  • Ejemplo:
    • O(VERDADERO, FALSO) = VERDADERO
    • O(FALSO, FALSO) = FALSO

FUNCIÓN SI

  • Descripción: La función SI comprueba si se cumple una condición y devuelve un valor si se evalúa como VERDADERO y otro valor si se evalúa como FALSO.
  • Sintaxis: =SI(Prueba_lógica;[Valor_si_verdadero];[Valor_si_falso])
    • Prueba_lógica: Es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO
    • Valor_si_verdadero: Es el valor que se devolverá si prueba_logica es VERDADERO. Si se omite, devolverá VERDADERO. Puede anidar hasta siete funciones SI.
    • Valor_si_falso: Es el valor que se devolverá si prueba_lógica es FALSO. Si se omite, devolverá FALSO. 
  • Ejemplo: =SI(A1>=100;”Objetivo alcanzado”;”Objetivo no alcanzado”)

FUNCIÓN SI.ERROR

  • Descripción: Devuelve un valor si la expresión es un error y otro valor si no lo es.
  • Sintaxis: SI.ERROR(valor; valor_si_error)
    • Valor (Obligatorio): Es cualquier valor, expresión o referencia.
    • Valor_si_error (Obligatorio): Es cualquier valor, expresión o referencia.
  • Ejemplo: SI.ERROR(A1, “Error de cálculo”) = Error de cálculo

FUNCIÓN SI.ND

  • Descripción: Devuelve el valor que específicas, si la expresión se convierte en #N/A. De lo contrario, devuelve el resultado de la expresión.
  • Sintaxis: SI.ND(Valor, Valor_si_nd)
    • Valor (obligatorio): Es cualquier valor, expresión o referencia
    • Valor_si_nd (obligatorio): Es cualquier valor, expresión o referencia. Es el valor devuelto en caso de que el argumento Valor sea evaluado como el error #N/A.

FUNCIÓN VERDADERO

  • Descripción: Devuelve el valor lógico VERDADERO.
  • Sintaxis: VERDADERO()

El resultado de la fórmula = VERDADERO

FUNCIÓN XO

  • Descripción: Devuelve una “Exclusive Or” lógica de todos los argumentos.
  • Sintaxis: XO(Valor_lógico_1, Valor_lógico_2, …)
    • Valor_lógico_1 (obligatorio): Son las condiciones de 1 a 254 que quieres probar, que puede ser VERDADERO o FALSO, así como valores lógicos, matrices o referencias.
    • Valor_lógico_2 (opcional): Son las condiciones de 1 a 254 que quieres probar, que puede ser VERDADERO o FALSO, así como valores lógicos, matrices o referencias.

FUNCIÓN Y

  • Descripción: Comprueba si todos los argumentos son VERDADEROS y devuelve VERDADERO si todos los argumentos son VERDADEROS. Devuelve FALSO si alguno de los argumentos es FALSO.
  • Sintaxis: Y(valor_lógico1, [valor_lógico2], …)
    • Valor_lógico1 (obligatorio): Primera condición a probar. Son entre 1 y 255 condiciones que desea comprobar, que puede ser VERDADERO o FALSO y que pueden ser valores lógicos, matrices o referencias.
    • Valor_lógico2 (opcional): Condiciones adicionales a probar. Son entre 1 y 255 condiciones que desea comprobar, que puede ser VERDADERO o FALSO y que pueden ser valores lógicos, matrices o referencias.
  • Ejemplo:
    • Y(VERDADERO, VERDADERO) = VERDADERO
    • Y(VERDADERO, VERDADERO, FALSO) = FALSO

¿Necesitas ayuda?

Si quieres aprender mucho más sobre las funciones de Excel y todas las herramientas que te proporciona la hoja de cálculo, te invitamos a explorar nuestro curso de Excel donde aprenderás a aplicar todas las funciones y fórmulas de Excel de manera práctica.

Con este curso, conseguirás aprender Excel desde lo básico hasta lo avanzado, ¡te aseguro que no te arrepentirás!

Haz clic aquí para ver el Curso de Excel

Funciones lógicas en Excel

Entradas relacionadas

Entradas recientes